Monthly Archives: May 2012

Increase bandwidth by disabling QoS in Windows 7

Open Group Policy Management Console:

gpedit.msc

Navigate to Local Computer Policy > Administrative Templates > Network > QOS Packet Scheduler , then on the right window, click the Limit reservable bandwidth setting and select the Edit:

On the setting tab, check the enabled setting, and Where it says “Bandwidth limit %“, change it to 0:

Now, Open up the Network Connections:

ncpa.cpl

Right-click on the connection and select Properties :

Make sure QOS Packet Scheduler is enabled:

Hope this will help you!

Please Remember me in your prayers!

Advertisements

How to Enable Telnet Client on Windows 7

Telnet Client allows a computer to connect to a remote Telnet server and run applications on that server. Once logged on, a user is given a command prompt that can be used as if it had been opened locally on the Telnet server’s console. Commands that you type at the Telnet client command prompt are sent to the Telnet Server and executed there, as though you were locally logged on to a command prompt session at the server. Output from the commands that you run are sent back to the Telnet client where they are displayed for you to view.

When you first try to run a telnet command, Windows will informs you that telnet is not recognized as a command:

To enable Telnet Client on Windows 7, just follow these simple steps :

To confirm that Telnet  Client is installed Successfully: 

Real Life Test: I will connect to my DSL Modem to confirm that it is working properly!

Hope this will help you!

Please Remember me in your prayers!

Disable “This program might not have installed correctly” Message in Windows 7

If you are the type of person who installs a lot of software on your PC, then you may have seen the following message after successful installations:

Most of the time, the program I am installing,installs fine and this message is an inconvenience. In a quest to click my mouse less, I set out to disable this dialog box. Learn how to disable this also in this guide.

Disable “This program might not have installed correctly” Message

To disable the This program might not have installed correctly message:

1. Click the Start button, type services.msc, and press Enter:

2. Scroll down to Program Compatibility Assistant Service, right click it, and click Properties.
3. Change the Startup type to Disabled and click Stop.

Now you’ll no longer see this box and can use the saved mouse clicks and time!

Hope this will help you!

Please Remember me in your prayers!

How to install Gnome Classic on Ubuntu 12.04 LTS‏

To install the gnome classic on Ubuntu 12.04 LTS, press Ctrl + Alt + T and write this command:

sudo apt-get install gnome-session-fallback

To install the tweak tool:

sudo apt-get install gnome-tweak-tool

After that, reboot the system and when it will come online, perform the following steps:

To display the Computer and Trash Icons on the desktop, do this:

Hope this will help you!

Please Remember me in your prayers!

Installing the FreeNX server on Ubuntu 12.04 LTS

FreeNX is a system that allows you to access your desktop from another machine over the Internet. You can use this to login graphically to your desktop from a remote location. One example of its use would be to have a FreeNX server set up on your home computer, and graphically logging in to the home computer from your work computer, using a FreeNX client.

Open the terminal and write this command:

sudo add-apt-repository ppa:freenx-team

Then update the apt:

sudo apt-get update

Install the FreeNX:

sudo apt-get install freenx

Get the nxsetup script:

wget https://bugs.launchpad.net/freenx-server/+bug/576359/+attachment/1378450/+files/nxsetup.tar.gz

Unpack the nxsetup script:

tar -xvf nxsetup.tar.gz

Copy the setup script to /usr/lib/nx:

sudo cp nxsetup /usr/lib/nx/nxsetup

Run nxsetup:

sudo /usr/lib/nx/nxsetup --install

Restart the freenx-server service:

sudo /etc/init.d/freenx-server restart

Use the ifconfig command to find the ip address:

ifconfig

Download the FreeNX Client for Windows from here:

Once it’s install, it will place an icon on the desktop, double-click on the icon and follow these steps:

After accecpting the RSA key fingerprint, we will connect to FreeNX Server:

Hope this will help you!

Please Remember me in your prayers!

How to Configure Cisco Router with DSL (PTCL)!

In this tutorial, we will configure the cisco(3640) router as a gateway for our LAN. It takes IP setting from DSL (PTCL) Modem through dhcp, in order to access the Internet. This router also act as the DHCP and DNS Server for LAN!

In first step, we will configure fa0/0 interface to take the ip address from DSL Modem:

interface fa0/0
ip address dhcp
no shut

Next, we configure the ip address on fa1/0 interface:

interface fa1/0
ip address 10.10.10.1 255.255.255.0
no shut

Verify the ip address and interface(s) status:

show ip int brief

Now, we will configure this router as dhcp server in order to serve ip address settings to our LAN, we will use the 10.10.10.0/24 network, in which 10.10.10.1 will be the default gateway and dns:

service dhcp
ip dhcp excluded-address 10.10.10.1 10.10.10.20
ip dhcp pool LAN-Pool
 network 10.10.10.0 255.255.255.0
 default-router 10.10.10.1
 dns-server 10.10.10.1
 domain-name home.lan
 import all

Verify that our dhcp server, serves the ip address to LAN:

show ip dhcp binding

Now, we will configure the DNS setting on our router in order to provide DNS services to our network, and make all clients use it as a DNS server:

ip dns server
ip name-server 192.168.1.1
ip domain-lookup

Next step is to configure the NAT on our router, for this, we need to define  the inside and outside interfaces, fa0/0 is connected to the Internet, so it is outside while fa1/0 is connected to the internal network, so it is  inside!

interface FastEthernet0/0
ip nat outside
interface FastEthernet1/0
ip nat inside

Now,we need to create an ACL that will include local network(10.10.10.0/24)!

Next, we need to enable NAT overload and bind it to the outside interface:

Test from one of the LAN’s client:

Verify the NAT status on our cisco router:
show ip nat translations 

Hope this will help you!

Please Remember me in your prayers!

RIP routing between Cisco,Ubuntu and CentOS Router!

Scenario:

  • Routers: 1 Ubuntu Linux with 2 nics, 1 Centos Linux with 2 nics and 1 Cisco 3640 Router with 3 FastEthernet interfaces.
  • Clients: 3 Windows Xp with 1 nic.
IP Details

All the Routers in this scenario have a default password of “zebra.

3640Router:

  • fe0/0: 192.168.10.1/24
  • fe1/0:172.16.10.1 /24
  • fe2/0: 10.10.10.1/24

UbuntuRouter:

  • eth0: 192.168.10.2/24
  • eth1: 10.10.20.1/24

CentOSRouter:

  • eth0: 172.16.10.2/24
  • eth1: 10.10.30.1/24

Clients:

  • WinXP-1: 10.10.20.10/24
  • WinXP-2: 10.10.10.10/24
  • WinXP-3: 10.10.30.10/24
3640Router Configuration:

UbuntuRouter Configuration:

Restart the Router!!!

CentOSRouter Configuration:

Restart the Router!!!

Verification from Routers :-)

Test from Clients :-)

Make a simple test from WinXP-1.

Make a simple test from WinXP-2.

Make a simple test from WinXP-3.

Hope this will help you!

Please Remember me in your prayers!

SVN Server on CentOS 6 with Web Access

Before installing the SVN Server,disabled the SELinux:

sudo nano /etc/selinux/config

Make SELINUX=disabled:

Restart the Server!

To install SVN server, run this command at the command prompt:

sudo yum install httpd mod_dav_svn subversion

Make the Apache service to run automatically at boot time:

sudo chkconfig httpd on

Edit the subversion.conf file:

sudo nano /etc/httpd/conf.d/subversion.conf

Delete all the data and make it simple like this :

LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so
 
<Location /svn>
 DAV svn
 SVNParentPath /svn
 AuthType Basic
 AuthName "Subversion repositories"
 AuthUserFile /svnauth/auth
 Require valid-user
</Location>

Now, we create a separate directory where we will keep the authentication file:

sudo mkdir /svnauth
sudo chown -R apache.apache /svnauth/
sudo htpasswd -cm /svnauth/auth arbab

We only need to use the -c option for the FIRST TIME, when you create a user, after that you will only use the -m option.

After that, we make the directory where we want to keep the svn repositories and also create testrepo inside:

Make sure we set the permissions of the /svn directory to apache with the following command:

Restart the apache service:

sudo service httpd restart

Configure the iptables rule in order to allow access to the svn server:

sudo iptables -I INPUT 4 -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
sudo service iptables save

Now if we go to http://server-ip/svn/testrepo using web browser,it will ask for username and password:

Once we enter the correct username and password, we should see that the repository is enabled!

Now, we have a working subversion server!

Hope this will help you!

Please Remember me in your prayers!

Ubuntu as a firewall/gateway router

In this simple tutorial, I will show you how to configure the Ubuntu server as Internet gateway, which also serves as DHCP and DNS Server!

Scenario:
  1.  Ubuntu server with 2 Network Cards 1 is connected to Internet and named as WAN,which takes the ip address through dhcp and the other one is connected to the Local Network and named as LAN,which has static ip address 10.10.10.1/24.
  2. Windows Client(s), which takes ip address from Ubuntu Server, also use it as name resolution server (Internet) and gateway.
Prerequisite(s):
  1. Change the Network Cards name using this Tutorial.
  2. Install the Webmin, also using this Tutorial.

First, We will check the ip address setting for the above scenario:

sudo nano /etc/network/interfaces

It will show the ip address that associated with the each interface:

Now, we also examine the output of ifconfig command:

ifconfig

We need to install two packages to accomplish the goal of this tutorial:

sudo apt-get install isc-dhcp-server bind9

Because there is more than one network card(s) in Ubuntu server, so we need to select the network card on which our server will be listen for dhcp request. (By default, it listens on eth0/WAN in this case).
We can change this by editing the  /etc/default/isc-dhcp-server file:

sudo nano /etc/default/isc-dhcp-server 

Put LAN in the INTERFACES place:

Now we will change the default configuration by editing /etc/dhcp/dhcpd.conf, I normally delete everything inside the file and manually add the configuration that suits my needs :-)

sudo nano /etc/dhcp/dhcpd.conf

Here is my dhcpd.conf file, you need to change it according to your needs:

ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
authoritative;
log-facility local7;
option subnet-mask 255.255.255.0;
option broadcast-address 10.10.10.255;
option routers 10.10.10.1;
option domain-name-servers 10.10.10.1;
option domain-name "ubuntu.firewall";
subnet 10.10.10.0 netmask 255.255.255.0 {
range 10.10.10.50 10.10.10.200;
}

Restart dhcp service using the following command:

sudo service isc-dhcp-server restart 

To enable ip forwarding, edit /etc/sysctl.conf file:

sudo nano /etc/sysctl.conf

Uncomment the  net.ipv4.ip_forward=1:

Login to the Webmin using https://server-ip:10000, In my case it is,https://tendo-Firewall:10000.

Follow these steps in order to enable the MASQUERADE(NAT):

To save the Firewall(Iptables) setting, do this:

After saving the setting, check the /etc/network/interfaces file once again:

sudo nano /etc/network/interfaces

Notice that it added one line under LAN interface:

The purpose of this line is to enable the Masquerading, as soon as the interface LAN will up and running!

Test from Windows 7 that connect to LAN:

Hurry, We are able to access the Internet, this mean we configure the Ubuntu server as gateway successfully 🙂

Note: In order to secure this server we need to do some extra work, which I will show you really soon!

Hope this will help you!

Please Remember me in your prayers!

Change the Network Card name in Ubuntu 12.04

In this short tutorial, I will show you that how to change the NIC(s) name in Ubuntu 12.04.

First, we check the current NIC(s) name using ifconfig command:

ifconfig

eth0 is connected to the internet so, I want to give it a name: WAN

eth1 is connected to the Local Network, so I want to give it a name: LAN

To acheive this goal, just edit /etc/udev/rules.d/70-persistent-net.rules file:

sudo nano /etc/udev/rules.d/70-persistent-net.rules

By default, it assigns the name eth0,eth1 etc to the NIC(s):

Change it to whatever you want, like I want WAN for eth0 and LAN for eth1:

After that edit the /etc/network/interfaces file:

sudo nano /etc/network/interfaces

By default, it also assigns the name eth0,eth1 etc to the NIC(s):

Change it exactly the same as we assigned in the /etc/udev/rules.d/70-persistent-net.rules file, like WAN for eth0 and LAN for eth1:

Reboot the Ubuntu System!

After reboot, check your NIC(s) name using ifconfig command:

ifconfig

Hope this will help you!

Please Remember me in your prayers!

%d bloggers like this: