Tag Archives: ptcl

How to install Ptcl eVo on Ubuntu 12.04 LTS

Plug the eVo 3G modem and then click on the Network Manager and select Edit Connections:

Move to the Mobile Broadband tab and click on Add:

Select the 3G device and click Continue:

Select Pakistan from Next Screen and press Continue:

Select Ptcl EVO from provider screen and press Continue:

Click Apply:

In the new Window, Enter:

Username: vwireless@ptcl.com
Password: ptcl

Click  Close:

In order to connect,click on Network Manager icon in Taskbar and then select the newly created connection:

After a successful connection, It will look like this:

Troubleshooting:

If you are facing a problem that your computer doesn’t recognize the 3G device then install this:

sudo apt-get install usb-modeswitch usb-modeswitch-data

Hope this will help you!

Please Remember me in your prayers!

Advertisements

How to Configure Cisco Router with DSL (PTCL)!

In this tutorial, we will configure the cisco(3640) router as a gateway for our LAN. It takes IP setting from DSL (PTCL) Modem through dhcp, in order to access the Internet. This router also act as the DHCP and DNS Server for LAN!

In first step, we will configure fa0/0 interface to take the ip address from DSL Modem:

interface fa0/0
ip address dhcp
no shut

Next, we configure the ip address on fa1/0 interface:

interface fa1/0
ip address 10.10.10.1 255.255.255.0
no shut

Verify the ip address and interface(s) status:

show ip int brief

Now, we will configure this router as dhcp server in order to serve ip address settings to our LAN, we will use the 10.10.10.0/24 network, in which 10.10.10.1 will be the default gateway and dns:

service dhcp
ip dhcp excluded-address 10.10.10.1 10.10.10.20
ip dhcp pool LAN-Pool
 network 10.10.10.0 255.255.255.0
 default-router 10.10.10.1
 dns-server 10.10.10.1
 domain-name home.lan
 import all

Verify that our dhcp server, serves the ip address to LAN:

show ip dhcp binding

Now, we will configure the DNS setting on our router in order to provide DNS services to our network, and make all clients use it as a DNS server:

ip dns server
ip name-server 192.168.1.1
ip domain-lookup

Next step is to configure the NAT on our router, for this, we need to define  the inside and outside interfaces, fa0/0 is connected to the Internet, so it is outside while fa1/0 is connected to the internal network, so it is  inside!

interface FastEthernet0/0
ip nat outside
interface FastEthernet1/0
ip nat inside

Now,we need to create an ACL that will include local network(10.10.10.0/24)!

Next, we need to enable NAT overload and bind it to the outside interface:

Test from one of the LAN’s client:

Verify the NAT status on our cisco router:
show ip nat translations 

Hope this will help you!

Please Remember me in your prayers!

%d bloggers like this: